Who Am I ?
I’ve just created an interface named:
/// <summary>
/// Defines an object which support xml representation in the system.
/// </summary>
public interface ISupportXmlFormat
{
/// <summary>
/// Return the object representation as xml string.
/// </summary>
/// <returns>Xml string</returns>
string ToXml();
}
I know, this is a silly name but it made me laugh quite a bit so I thought to share with you my geeky sense of humor ;-)
It is hard sometimes to think about a good name for an interface. I general, I follow Roy Osherove‘s Interface naming guidelines and name my interfaces by their purpose or “what can be done to them”.
Do you have a better name to suggest ?