Overload or different naming ?
I need two methods which will bring me some data.
1st scenario: bring the data from the file system.
Method name: GetData(string directory, string[] files)
2nd scenario: bring the data from a dll (assembly) file. The data is an embedded Resource inside the assembly.
Method name: GetData(string assemblyName, string prefixPath, string[] files)
They both sit in some Helper (static)class.
Now, I thought about changing the method names into GetDataFromFS and GetDataFromAssembly. The fact that they are both serve the same purpose makes me feel that this should be a simple overload but yet I feel that this is wrong somehow due to the fact that their domain is quite different. If tomorrow I’ll add GetData(string webServiceUrl, string[] files) should it be overload as well? I must say I’m not so sure…
What do you think ? overload or naming by domain[1] ?
[1] – No. I don’t want some factory and concrete classes or strategy pattern implementation; This should be a simple utils class.